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Exploring Supply Dynamics in Competitive Markets 

 
Introduction 

Understanding the ebb and flow of competitive markets is essential for students pursuing a 

variety of undergraduate degrees.  Competitive markets, in the academic setting, are central to all types 

of economic and business majors, but are most generally studied in a static setting.  Competitive 

markets are not limited to the academic setting, but are integral in the daily life of anyone who is a 

consumer or producer.  The objective of this paper is to develop a dynamic simulation model, with 

curriculum materials, that introduces users to interactions occurring in the supply side of competitive 

markets. 

 This model is geared toward, but by no means limited to, undergraduate economic courses.  

The model shows specific relationships graphically and mathematically, so it is appeals to different 

learning styles.  It allows users to easily make changes to any aspect of the market and immediately see 

how those changes affect all other aspects of the market.  This model brings tangibility and simplicity to 

an intangible, complex concept of the competitive market.  It could easily be used alone, or in 

conjunction with other methods, to introduce students to the dynamics of a competitive market and 

simulation modeling.  

It is important for students to learn about conceptual models because the conceptual model is 

the link between theory and empirical models.  Conceptual models allow students to apply economic 

theory to investigate a research question.  The conceptual model is not limited by the data available.  It 

is important for students to mentally develop an ideal model.  The conceptual model can contain all 

elements that students believe need to be included in it.  The conceptual model is the ideal, and the 
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empirical model is as close as economists can get with the data available.  Often the economic models 

rely on complex mathematics and statistics.  The system dynamic approach allows students to be 

introduced to modeling without the potential barrier of the mathematics.  System dynamic models allow 

the students to focus on the economic aspects of the subject rather than the mathematical techniques.   

This simulation model uses a System Dynamics framework.  A simulation model attempts to 

simulate economic interactions in different markets to examine policy and theoretical impacts.  System 

Dynamics models can be easily changed and “what if” scenarios can be easily created by modelers.  In 

simulation modeling, variables can be classified as either endogenous or exogenous.  Exogenous 

variables are those variables that are determined outside the model, usually through assumptions.  

Endogenous variables are determined within the model using interactions built into the model and are 

generally the focus of interest.  

This model is designed using a visual system dynamics framework (Appendix I - Figure 1), and 

is based on the sample problem located in Appendix II.  While there are certainly mathematical formulas 

underlying and driving the model, the visual format allows students to develop a mental model of the 

system’s structure and see market interactions through the causal loops.  Within a system dynamics 

framework, the competitive market is dynamic where prices, the number of firms, firm output, and other 

elements of the system are all changing over time. These changes are the result of interactions among the 

elements that constitute the system.  To understand the changes, we should understand the related 

system.  Elements of the system interact through feedback loops, as the building blocks of all dynamic 

systems.  Feedback loops consist of accumulations, or level variables (the number of firms and their 

output), rate variables that drive level changes (firm entry and exit rate, rate of firm output adjustment), 

and information levels connecting level to rate variables (profitability and price levels). Simultaneous 
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active feedback loops create the dynamics in this situation.  Generally, the human mind is not capable of 

perceiving the dynamic consequences of a number of simultaneously active feedback loops.  However 

with the interactive software, students are capable of isolating feedback loops and freezing time to 

enhance understanding.  

This particular model has two feedback loops. The Price-Output per Firm loop allows 

students to explore the interaction between price, marginal cost, and output per firm with the ability to 

easily alter marginal cost and the rates of increasing or decreasing output.  The Profitability-Number of 

Firms loop allows the student to explore the relationships between price, fixed and variable costs, 

profitability, and firm entry or exit rate, with the ability to quickly alter these parameters.  The simplicity 

of the model allows users that are unfamiliar with system dynamics models an easy introduction to this 

area of modeling.  This model eases the introduction of system dynamics into the economic arena by 

focusing on a basic economic concept, the supply side of a competitive market.  The included 

curriculum materials give instructors several activities for each aspect of the model, focusing on how the 

structure of the market can generate either dynamically stable, equilibrating markets or dynamic 

disequilibria. 

Finally, the model contributes significantly to the economic literature.  System dynamics has 

been widely used in business fields, but is fairly new to the economic arena.  Although, competitive 

markets are studied in business fields, the structure generally takes on more of an accounting rather than 

economic approach.  This model is a unique merger of business and economics, using platforms familiar 

to both areas.  The teaching activities can be adapted to any content.  This flexibility and global 

perspective enables the model to be extremely educational to a wide variety of disciplines.  
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This paper has been organized so that an instructor can provide this document  as a class 

handout.  Directions for downloading and using the software are included in the next section, “Becoming 

Familiar with Vensim PLE”.  An overview of the model, with a discussion of the dynamic components, 

is summarized in “Understanding the Model”.  To familiarize users with Vensim, a “Sample Simulation” 

section is included.  The last section is comprised of example exercises.  The first exercise focuses on 

“Dynamic Stability in Competitive Markets”, while the second exercise explores “Equilibration in 

Competitive Markets”.  In the third exercise, factors contributing to “Dynamic Instability in Competitive 

Markets” are discussed. 

Becoming Familiar with Vensim PLE 

Vensim Personal Learning Edition (PLE) is simulation software used to develop and analyze 

dynamic feedback systems. It is available, free of charge from Ventana Systems, Inc., and can be 

downloaded from their website at http://www.vensim.com/download.html.  The student should 

download and install the software as per the instructions on the website.  Be sure to download and save 

all six disks prior to running the executable file on Disk 1.  After installation go to Start → Programs → 

Vensim, and open VensimPLE.  Then go to Help → Vensim Manuals → User’s Guide → 2, The 

Vensim User’s Interface, and review the topics listed.  It will be convenient to print the topics Tool 

Bars, Sketch Tools, and Analysis Tools for future reference. While it is not required to complete the 

following exercises, the student is encouraged to work through topic 3, A Hands on Example, in the 

User’s guide. 

Understanding the Model 

The system dynamic model (Appendix I - Figure 1) is based on the sample problem located in 

Appendix II.  Prior to examining the structure of the model, the student should work through the sample 
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problem.  After becoming familiar with the math associated with the problem, open VensimPLE.  

Using File → Open Model command, open the file “simple S&D.mdl”. This file is available from your 

instructor and will run better if loaded from your hard drive. Occasionally, the model is too large to see 

on one screen.  In this case, then use the View → Zoom → Fit to Screen command to resize the model.  

Your screen should now look like Figure 2. 

The model is composed of many variables.  The Number of Firms, Aggregate Supply, and 

Profit are a few examples of model variables.  The model is composed of two causal feedback loops.  

The right loop is named the Price-Output per Firm loop, and it models how firms adjust their output 

depending on the market price.  The left loop is the Profit-Number of Firms loop, and it models how 

firms enter and exit the market depending on the profitability of the industry. Within a system dynamics 

framework, the arrows portray the direction of causality between variables.  As an example, you can 

see that Aggregate Supply is caused by both Number of Firms and Production per Firm.  While this 

tells us what causes Aggregate Supply, it does not specify how it is caused.  To see the specifics of 

how Number of Firms and Production per Firm interact, select the equation tool on the sketch tool 

toolbar (one left click of the mouse), and then select the variable  Aggregate Supply (one left click of 

the mouse).  This procedure opens the equation editor (Figure 3).  We can now see that the 

mathematical specification is        *AggregateSupply Numberof Firms ProductionperFirm= .  

Click OK to close the equation editor window. 

Price is simultaneously determined by the interaction between demand and supply. In this model 

aggregate demand is assumed to be fixed and constant primarily to isolate the supply side interactions.  

The demand curve is composed of two variables, Demand Curve-Intercept and Demand Curve-

Slope.  On the sketch tool toolbar select the equation tool (one left click of the mouse), and then 
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select the variable Demand Curve-Intercept (one left click of the mouse).  This procedure opens the 

equation editor.  We can now see that the mathematical specification is Demand Curve-

Intercept=22.  Click OK to close the equation editor window.  Use the equation editor to verify the 

mathematical specification for Demand Curve-Slope is Demand Curve-Slope = .0001.  Now, use the 

equation editor to verify the mathematical specification for   Price is Price = max((Demand Curve - 

Intercept-Aggregate Supply*Demand Curve - Slope),0). The use of the max-min function insures that 

price will never go below zero.  This is exactly the same specification as given in equation #1 of the 

sample problem (Appendix II). 

Focusing on the Price-Output per Firm loop lets the instructor review the concept of marginal 

cost.  Within competitive markets, firms are assumed to be price takers.  This means that firms take 

their input and output prices as given, and maximize profit by choosing their quantity of production 

(equation #2 of the sample problem).  In perfectly competitive markets, the quantity that will maximize 

profit is when output price = marginal cost.  Now use the equation editor to verify the mathematical 

specification for Marginal Cost = .04 and Desired Production = Price/Marginal Cost. This is 

exactly the same specification as given in equation #3 of the sample problem (Appendix II).  

We used economic theory to guide the model development; however theory only tells us how to 

arrive at a firm’s optimal production quantity to maximize profits.  Theory does not specify the 

mechanics of moving from one production level to another.  If a firm is underproducing, then time is 

required to add equipment and people, as well as to obtain the financial requirements for increased 

production.  On the other hand if a firm is overproducing, then asset reduction is equally difficult.  From 

this perspective we need to recognize that production quantities are ‘sticky’, and explicitly incorporate 

into the model the rates at which production can change.  This requires assumptions that by their nature 
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are abstractions from reality. It will be these assumptions that will create the dynamics of our 

competitive model.  Use the equation editor to review the mathematical specifications for Rate of 

Increasing Production and Rate of Decreasing Production.  Using the equation editor we see that 

Feasible Change in Production = IF THEN ELSE(Production per firm<Desired production, 

(Desired production-Production per firm)*Rate of increasing output, (Desired production-

Production per firm)*Rate of decreasing output.  This simply indicates that a firm can increase or 

decrease production based on 10% of the difference between current production and desired 

production.  Use the equation editor to review the mathematical specification for Change in 

Production and Maximum Output Capacity.  This specification indicates that the Change in 

Production will equal the Feasible Change in Production, unless that change will cause the firm to 

exceed its Maximum Output Capacity.  

To complete the Price-Output per Firm loop use the equation editor to review the 

mathematical specification for Production per Firm.  We started our simulation model, in the first time 

period, with an initial value for Production per Firm, and saw how this quantity impacted the price.  

Based on our assumptions and the current market price, the firm decided how to change their 

production quantity.  One can now simulate the second period where Production per Firm = Initial 

Production per Firm + Change in Production.   

The left loop is the Profit-Number of Firms loop, and it models how firms enter and exit the 

market depending on profitability.  Using the equation editor examine the mathematical specifications 

for Impact of Production on Cost, Variable Expenses, Fixed Expenses, and Profit.  The Variable 

Expenses are the product of Marginal Cost and the number of units produced per firm.  The Marginal 

Cost and Fixed Expenses are assumptions built into the model and are easily changed to be industry 
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specific.  Notice that the specification for Profit is exactly the same as equation #2 in the sample 

problem.  Economic theory implies that if profits are positive (negative), then firms will enter (exit) the 

market.  Similar to the firm’s decision to alter the quantity of output, theory does not specify exactly 

how, or in what quantities, firms will enter the market.  Because of the need to quantify the change, we 

need to make assumptions to model firm entry and exit.  Using the equation editor examine Entry 

Rate and Exit Rate.  The specification is: Change in the Number of Firms = IF THEN 

ELSE(Profit=0, 0, IF THEN ELSE(Profit>0, Entry Rate, IF THEN ELSE(Profit<0, -Exit Rate, 

0))).  This equation indicates that if profits are positive, then the change in the quantity of new firms is the 

Entry Rate, and if profits are negative, then the change in the quantity of new firms is the Exit Rate.  

These assumptions are easily changed according what the modeler believes is reasonable or chooses to 

test.  

To complete the Profit-Number of Firms loop use the equation editor to review the 

mathematical specification for Number of Firms.  We began our simulation model, in the first time 

period, with an initial value for Number of Firms, and saw how this quantity impacted the price.  Based 

on our assumptions and the current market price, the market decided how to change this number based 

on profitability.  We can now simulate the second period where Number of Firms = Initial Number 

of Firms + Change in Number of Firms. 

The flexibility of system dynamic models is the key to their importance in teaching future 

economists.  In 1936, Keynes said that the nature of economic thinking was not to create an infallible 

method of blind manipulation to furnish an answer, but to develop an organized and orderly method of 

thinking out particular problems (Keynes, 1936).  System dynamic models are excellent tools for 

students to explore ways to solve economic problems.  These models are easy to build and change.  



 10

This facet enables users to be involved in the entire model building process, rather than blindly plugging 

data into someone else’s model.  In developing one’s own model, one knows all the assumptions, 

limitations, and strengths of the model.  The ease of model building and the ease of changing the model 

are the major assets of using system dynamic models.  

Sample Simulation 

Using the equation editor set Initial Number of Firms = 400, Initial Production per Firm = 

40, Rate of Increasing Production = Rate of Decreasing Production=0.05, Entry Rate = Exit 

Rate =0.  On the Menu bar go to Model → Settings and change the Final Time to 10.  On the Main 

Toolbar click on the Simulate button (running man with green dot).  Answer yes to the question – do 

you want to override current data set, if the pop up screen appears.  You have now successfully 

simulated the model.  Suppose you want to know how price changed over the 10 year simulation 

period.  On the Sketch toolbar click once on the lock button, and select the variable Price by clicking 

on it.  On the Analyses toolbar click once on the Graph button.  A time-series graph of price should 

appear on the screen (Figure 4, Appendix II).  Close the graph and click once on the Table button on 

the Analyses toolbar.  This is the same data as presented in the graph except it is in tabular form and 

can easily be copied to a spreadsheet package, if needed.  Close the table, select the Production per 

Firm variable by clicking on it.  On the Analyses toolbar click once on the Graph button, to see how 

Production per Firm changes over time.  This process can be repeated for any variable that is 

selected. 
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Exercise 1: Dynamic Stability in Competitive Markets 
1) In simulation modeling variables can be classified as either endogenous or exogenous. 

Exogenous variables are those variables that are determined outside the model, generally 
through assumptions. Endogenous variable are determined by the model and are generally the 
focus of interest. List the endogenous and exogenous variables in this model. 

2) On the toolbar click once on the control panel icon. The control panel window will open and 
click once on the Datasets tab. Select current from the loaded-info window and move it to 
the available-info window. With current selected delete the dataset and close the window. 
Using the equation editor set Initial Number of Firms = 400, Initial Production per Firm 
= 40, Rate of Increasing Production = Rate of Decreasing Production=0.05, Entry Rate 
= Exit Rate =0. On the Menu bar go to Model → Settings and change the Final Time to 10. 
On the toolbar change the runname to Normal Marginal Cost, and simulate the model. Using 
the equation editor set Marginal Cost = .06, and Impact of Production on Cost =.03. On 
the toolbar change the runname to High Marginal Cost, and simulate the model. Using the 
equation editor set Marginal Cost = .02, and Impact of Production on Cost =.01. On the 
toolbar change the runname to Low Marginal Cost, and simulate the model. You now have 
three simulation datasets. Using either the Graph or Table analyses tool describe how marginal 
cost impacts Profit, Price, and Production per Firm when firms can neither enter or exit the 
market. 

3) Are The three markets from question 2 stable? 
4) On the toolbar click once on the control panel icon. The control panel window will open and 

click once on the Datasets tab. Delete the three datasets created in question 2. Using the 
equation editor set Initial Number of Firms = 380, Initial Production per Firm = 50, Rate 
of Increasing Production = Rate of Decreasing Production=0, Entry Rate = Exit Rate 
=2. On the Menu bar go to Model → Settings and change the Final Time to 20. On the 
toolbar change the runname to Normal Fixed Cost, and simulate the model. Using the 
equation editor set Fixed Cost = 25, on the toolbar change the runname to Low Marginal 
Cost, and simulate the model. Using the equation editor set Fixed Cost = 75, on the toolbar 
change the runname to High Fixed Cost, and simulate the model. You now have three 
simulation datasets. Using either the Graph or Table analyses tool describe how Fixed Costs 
impacts Profit, Price, and Number of Firms when firms can neither raise or lower the 
Production. 

5) Are the three markets from question 4 stable? 
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Exercise 2: Equilibration in Competitive Markets 
1) On the toolbar click once on the control panel icon. The control panel window will open and 

click once on the Datasets tab. Delete the three datasets created in exercise 1,question 4. 
Using the equation editor set Initial Number of Firms = 350, Initial Production per Firm = 
45, Rate of Increasing Production = Rate of Decreasing Production=.15, Entry Rate = 
Exit Rate =1,and Fixed Cost = 50. On the Menu bar go to Model → Settings and change 
the Final Time to 100. On the toolbar change the runname to Normal Quantity Change, and 
simulate the model. Using the equation editor Using the equation editor set Rate of 
Increasing Production = Rate of Decreasing Production=.10, on the toolbar change the 
runname to Slow Quantity Change, and simulate the model. Using the equation editor set 
Rate of Increasing Production = Rate of Decreasing Production=.175, on the toolbar 
change the runname to Fast Quantity Change, and simulate the model. You now have three 
simulation datasets. Using either the Graph or Table analyses tool describe how a firms ability 
to adjust quantity produced based on price signals impacts Profit, Price, Production per Firm 
and Number of Firms. Note: resizing the graph will help see the impacts more clearly. 

2) Are the three markets from question 1 stable? 
3) Does Price equilibrate around the equilibrium value found in the sample problem? Why or why 

not? 
4) Does Number of Firms equilibrate around the equilibrium value found in the sample problem? 

Why or why not? 
5) Does Production per Firm equilibrate around the equilibrium value found in the sample 

problem? Why or why not? 
Note: As an aid in answering questions 3 through 5, open the control panel window, on the graph 
tab choose ‘ALL_VARIABLES’ and display. The displayed table is the results of the last 
simulation for all variables. 
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Exercise 3: Dynamic Instability in Competitive Markets 
1) To this point we have evaluated markets that are somewhat symmetrical in nature. We have 

assumed that both the starting values of Number of Firms and Production per Firm are 
below the market equilibrium points. Additionally be have assumed that Rate of Increasing 
Production = Rate of Decreasing Production and Entry Rate = Exit Rate. On the 
toolbar click once on the control panel icon. The control panel window will open and 
click once on the Datasets tab. Delete the three datasets created in exercise 2,question 1. 
Using the equation editor set Initial Number of Firms = 420, Initial Production per 
Firm = 45, Rate of Increasing Production =.185, Rate of Decreasing 
Production=.115, Entry Rate =3, and  Exit Rate =1,. On the Menu bar go to Model → 
Settings and change the Final Time to 100. On the toolbar change the runname to 
Unsubsidized, and simulate the model. Using either the Graph or Table analyses tool 
describe the results. Include comments on: Is the market stable? What is the relationship 
between Number of Firms, Production per Firm, and Aggregate Supply. Why, in 
general are Profit and Price always below the equilibrium level of the sample problem? 

2) Suppose the government decides to stabilize the market by providing a lump sum subsidy to 
the firms in this market. To see what would happen we need to add a variable Subsidy to 
the model. On the Sketch toolbar click once on the Variable icon, and click one time on a 
clear space under the Profit-Number of Firms loop. A text box will appear, type in the 
variable name as Subsidy, and on the Sketch toolbar click once on the Lock icon on the 
Sketch toolbar. Now we need to specify the relationship between Subsidy and Profit. On 
the Sketch toolbar click once on the Arrow, once on Subsidy, once on Profit, and once 
on the Lock icon on the Sketch toolbar. An arrow should appear connecting Subsidy to 
Profit. Using the equation editor, open Subsidy, set it equal to 25, and set the units to 
‘dollars/firms’. Using the equation editor, open Profit, and add at the end of the existing 
equation ‘+subsidy’. On the toolbar change the runname to Subsidized, and simulate the 
model. . Using either the Graph or Table analyses tool describe the results. Include 
comments on: Is the subsidized market stable? Is Price in general higher or lower in the 
subsidized market? Is the variability in Price higher or lower in the subsidized market? What 
happened to firm profitability in the subsidized market? Why do so many firms enter the 
subsidized market? Overall does the government subsidy help or hurt producers and 
consumers. 

3) In order to simulate the behavior of this market we have made several assumptions about 
the structure of the market, and agent behavior. That is we have made assumptions about 
the initial Number of Firms and Production per Firm, as well as Rate of Increasing 
Production, Rate of Decreasing Production, Entry Rate, and Exit Rate. We have also 
made assumptions how these variables impact other variables. If we change these 
assumptions will we get the same results as we did in question 1 and 2 of exercise 3? 
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Appendix I 

 
 
 
 

 

Number of
FirmsChabge in number

of firms

Production
per firm

Change in
production

Aggregrate Supply

Demand Curve - SlopeDemand Curve - Intercept

Price

Profit

Marginal Cost

Desired
production

Maximum Output Capacity

<Production per firm>

Variable expense

Impact of production on cost

Rate of increasing output

Fixed expenses

Exit rate
Entry Rate

Rate of decreasing output
Desired change in

production

The Dynamics of  Supply in Competitive Markets

Price-Output per FirmProfit-Number of Firms

Figure 1 

 

 Figure 2 

 



 15

 
 
 

 Figure 3 

 

 Figure 4 

 



 16

Appendix II - Sample Problem 
 
Consider a competitive market composed of n identical firms and 1000 identical consumers. Each firm 
has a cost function: 2( ) .02 50, 1,2,3,...,i iC q q i n= + = . Each consumer has an inverse demand 
function: ( ) 22 , 1,2,3,...,1000i ip q q i= − = . 

1) Find the individual firm’s supply’ the market supply, the market demand, equilibrium price and 
equilibrium quantity. 

2) Firms enter and exit the market according to the level of profit. Find the equilibrium price, 
quantity, and the equilibrium number of firms. 

 
Answer: 

1) 
1000 1000

1 1

(22 ) 22000 1000 22 .001 [ #1]D i D
i i

Q q p Q p p Q eq
= =

= = − ⇒ = − ⇒ = −∑ ∑  

Firms solve the problem: 2. .02 50 [ #2]i iMax pq q eqπ = − −  
.04

/.04 25 [ #3]
i

i

p q MC
q p p eq

⇒ = =
⇒ = =

 

1 1

25 25
n n

S i i S
i i

Q q p Q np
= =

= = ⇒ =∑ ∑  

At equilibrium 
22000 550000 550000

* & * & *
(1000 25 ) (1000 25 ) (1000 25 )S D i

n
Q Q p Q q

n n n
= ⇒ = = =

+ + +
 

Firms will enter the market until economic profits are zero: 2( *)( ) .02 50 0i ip q qπ = − − =  which yields 
400 * 2 50in p q= = =    
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